锐捷配置DHCP服务

释放双眼,带上耳机,听听看~!

一、组网要求:
1) PC1能自动获取vlan2的地址,PC2能自动获取vlan3地址;
2) PC1、PC2的网关在三层交换机上;
3) mac地址为0002.b304.1265的PC能固定获取到192.168.2.2的地址;

二、组网拓扑:

三、配置要点:
1) service dhcp为dhcp的功能开关,不可遗漏;
2) DHCP地址池里可用地址的个数要是实际用户数的2倍左右;
3) 如果客户流动性比较大,如酒店环境,DHCP的释放时间lease不可配置为永久。否则有大量地址不释放导致新用户获取不到地址。一般配置为1~2小时

四、配置步骤:
注意:配置之前建议使用 Ruijie#show interface status查看接口名称,常用接口名称有FastEthernet(百兆)、GigabitEthernet(千兆)和TenGigabitEthernet(万兆),以下配置以千兆接口为例。

1) 新建vlan 2、3
Ruijie>enable
Ruijie#configure terminal
Ruijie(config)#vlan 2   ——>创建vlan 2
Ruijie(config-vlan)#exit
Ruijie(config)#vlan 3
Ruijie(config-vlan)#exit

2) 划分接口到相应vlan下
Ruijie(config)#interface GigabitEthernet 0/23
Ruijie(config-if-GigabitEthernet 0/23)# switchport access vlan 3   ——> 把交换机的第23个接口划入到vlan 3
Ruijie(config)#interface GigabitEthernet 0/24
Ruijie(config-if-GigabitEthernet 0/24)# switchport access vlan 2
Ruijie(config)#intterface range GigabitEthernet0/19 -22     ——>-从19到22范围端口一起划入vlan2
Ruijie(config-if-range)#switchport access vlan 2

3) 配置vlan2和vlan3的svi口地址(vlan网关地址)
Ruijie(config)#interface vlan 2
Ruijie(config-if-VLAN 3)#ip address 192.168.2.254 255.255.255.0
Ruijie(config-if-VLAN 3)#exit
Ruijie(config)#interface vlan 3
Ruijie(config-if-VLAN 3)#ip address 192.168.3.254 255.255.255.0
Ruijie(config-if-VLAN 3)#exit

4) 开启DHCP功能
Ruijie(config)#service dhcp

5) 配置DHCP地址池
Ruijie(config)#ip dhcp pool vlan2   ——>创建一个名为 valn2 的DHCP地址池
Ruijie(dhcp-config)#lease 1 2 3       ——>1、2、3分别是天、时、分,地址释放时间默认为24小时。
Ruijie(dhcp-config)#network 192.168.2.0 255.255.255.0   ——>可以分配的地址是192.168.2.1~192.168.2.253
Ruijie(dhcp-config)#dns-server 8.8.8.8  6.6.6.6      ——>8.8.8.8为主DNS,6.6.6.6为备用DNS
Ruijie(dhcp-config)#default-router 192.168.2.254  ——>分配的网关地址
Ruijie(dhcp-config)#exit

Ruijie(config)#ip dhcp pool vlan3
Ruijie(dhcp-config)#network 192.168.3.0 255.255.255.0
Ruijie(dhcp-config)#dns-server 8.8.8.8
Ruijie(dhcp-config)#default-router 192.168.3.254
Ruijie(dhcp-config)#exit

6) 保留部分地址
ruijie(config)#ip dhcp excluded-address 192.168.2.1 192.168.2.10    ——>不向客户端分配192.168.2.1~~192.168.2.10的地址

7) 配置DHCP静态分配地址
Ruijie(config)#ip dhcp pool test
Ruijie(dhcp-config)# client-identifier 01bc.aec5.4bca.8d    ——>针对固定MAC:bcae.c54b.ca8d,加上以太网标识01,即变为01bc.aec5.4bca.8d
Ruijie(dhcp-config)# host 192.168.2.2 255.255.255.0  ——>分配的ip地址和掩码
Ruijie(dhcp-config)# dns-server 8.8.8.8 6.6.6.6    ——>分配的主DNS8.8.8.8 和备用的DNS 6.6.6.6
Ruijie(dhcp-config)# default-router 192.168.2.254  ——>分配的网关

8)保存配置
Ruijie(dhcp-config)#end
Ruijie#write         ——>确认配置正确,保存配置

五、验证命令:
Ruijie#show ip dhcp binding
已下发的ip地址      客户端标识(01+mac)    地址租期                    地址分配方式
IP address        Client-Identifier/               Lease expiration                 Type
Hardware address
192.168.2.1       01bc.aec5.4bca.8d         000 days 23 hours 59 mins   Automatic

给TA买糖
共{{data.count}}人
人已赞赏
技术

dhcp snooping原理

2018-5-9 13:57:31

技术网络技术

锐捷配置DHCP中继

2018-5-9 15:55:08

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索